ubuntu

apache2配置文件缺失

Submitted by dravenk on Fri, 01/06/2017 - 02:59

完全卸载apache2后重新安装

sudo apt-get --purge remove apache2 
sudo apt-get --purge remove apache2.2-common 
sudo apt-get autoremove
sudo find  /etc -name "*apache*" -exec  rm -rf {} \;

卸载完后重新安装

sudo apt-get install apache2 
sudo /etc/init.d/apache2 restart

 

ubuntu安装QQ教程——解决ubuntu安装QQ以及安装QQ后出现的问题

Submitted by dravenk on Sat, 12/17/2016 - 00:21

之前不用ubuntu作为桌面系统的一大原因是QQ装不上啊,虽然Ubuntukylin给了wineQQ的安装包,但是当解压后执行

dpkg -i wine-qqintl_0.1.3-2_i386

却报错,去找了一些教程,但是都没能解决问题,也有可能是因为当时安装完ubuntu后安装了某些软件,把qq的一些依赖库卸了,今天再次下载QQ,试着把之前没解决的问题解决一下。

ubuntu下安装mariadb并设置密码

Submitted by dravenk on Sat, 12/10/2016 - 02:57

昨天在本地搭建web开发环境时候,安装了mariadb作为数据库存储服务。安装的时候没怎么注意,提示设置密码的时候请求设置root用户密码,我没输入密码,直接跳过了。之后试着登录,使用几个密码都不对,因为之前也安装过了mysql,不过卸载了而已,所以以为密码是旧的密码,忘了而已。

今天在试了设置匿名用户登录等方法,但都出岔子。

由于我之前没有进行数据库安全配置,所以重新进行数据库安全配置就能登录了。

sudo su //切换到root用户操作
mysql_secure_installation //进行数据库安全配置

对数据库安全配置都就能进去mysql/进行操作 了。

ubuntu更新失败

Submitted by dravenk on Thu, 12/01/2016 - 04:34

上个月才又把笔记本安装了ubuntu,所以也没对系统更新,今天安装一个软件时候系统报错,

E: 仓库 “cdrom://Ubuntu 16.10 _Yakkety Yak_ - Release amd64 (20161012.2) yakkety Release” 没有 Release 文件。
N: 无法安全地用该源进行更新,所以默认禁用该源。
N: 参见 apt-secure(8) 手册以了解仓库创建和用户配置方面的细节。

主要是系统安装后,安装或者更新系统会检查CDrom安装源,也就是检查本地的CD安装文件是否有这个软件包或者更新。使用vim把系统软件源的cd源注释掉就可以执行安装和更新了

sudo vim /etc/apt/sources.list